#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Support Escalations*[\s\S]*?Level IV.*"
Local $sString = "<td valign="top"><br>" & @CRLF & _
"<br>" & @CRLF & _
"John Doe<br>" & @CRLF & _
"Example, Inc. <br>" & @CRLF & _
"<br>" & @CRLF & _
"Office: 212.777.9999 x295<br>" & @CRLF & _
"jdoe@example.com| transbeam.com <br>" & @CRLF & _
"<br>" & @CRLF & _
"Support Escalations<br>" & @CRLF & _
"Level I: NOC Technician - support@example.com | O: 989.571.1000<br>" & @CRLF & _
"Level II: Manager, Network & Eng Operations, William Tell - wchen@example.com | O: 212.777.9999 x123 | M: 989.265.9876<br>" & @CRLF & _
"Level III: Vice President, Operations, Blaise Pascal - blaisep@example.com | O: 212.777.9999 x234 | M: 343.301.2822 <br>" & @CRLF & _
"Level IV: Chief Operating Officer: BF Skinner - bskinner@example.com | O: 212.777.9999 x345 | M: 343.337.7775<br>" & @CRLF & _
"<br>" & @CRLF & _
" <br>" & @CRLF & _
"<br>" & @CRLF & _
"From: Example Tech Support <br>" & @CRLF & _
"Sent: Monday, August 7, 2017 3:27 PM<br>" & @CRLF & _
"To: Example Tech Support <support@example.com>; 'nocdata@sample.com' <nocdata@sample.com><br>" & @CRLF & _
"Subject: RE: 81434 | WIN - Reparian Riverfront - EoC 10MB - Partial Impact<br>" & @CRLF & _
"<br>" & @CRLF & _
"Sample Support,<br>" & @CRLF & _
"<br>" & @CRLF & _
"Please be advised all loops have been repaired for this customer and they are currently up at their Full Bandiwdth.<br>" & @CRLF & _
"As this is stable, We will close this ticket out.<br>" & @CRLF & _
"<br>" & @CRLF & _
"Please let us know if you have any questions.<br>" & @CRLF & _
"<br>" & @CRLF & _
"Thank you,<br>" & @CRLF & _
"<br>" & @CRLF & _
"John Doe<br>" & @CRLF & _
"Example, Inc. <br>" & @CRLF & _
"<br>" & @CRLF & _
"Office: 212.777.9999 x295<br>" & @CRLF & _
"jdoe@example.com| transbeam.com <br>" & @CRLF & _
"<br>" & @CRLF & _
"Support Escalations<br>" & @CRLF & _
"Level I: NOC Technician - support@example.com | O: 989.571.1000<br>" & @CRLF & _
"Level II: Manager, Network & Eng Operations, William Tell - wchen@example.com | O: 212.777.9999 x123 | M: 989.265.9876<br>" & @CRLF & _
"Level III: Vice President, Operations, Blaise Pascal - blaisep@example.com | O: 212.777.9999 x234 | M: 343.301.2822 <br>" & @CRLF & _
"Level IV: Chief Operating Officer: BF Skinner - bskinner@example.com | O: 212.777.9999 x345 | M: 343.337.7775<br>" & @CRLF & _
"<br>" & @CRLF & _
" <br>" & @CRLF & _
"<br>" & @CRLF & _
"From: Example Tech Support <br>" & @CRLF & _
"Sent: Thursday, August 3, 2017 9:24 AM<br>" & @CRLF & _
"To: Example Tech Support <support@example.com>; 'nocdata@sample.com' <nocdata@sample.com><br>" & @CRLF & _
"Subject: RE: 81434 | WIN - Reparian Riverfront - EoC 10MB - Partial Impact<br>" & @CRLF & _
"<br>" & @CRLF & _
"Correction. The commit on the new ticket (loop 4) is 08/16. Apologies for the error.<br>" & @CRLF & _
"<br>" & @CRLF & _
"-------------------------------------<br>" & @CRLF & _
"Judy Garland<br>" & @CRLF & _
"NOC Technician<br>" & @CRLF & _
"<br>" & @CRLF & _
"From: Example Tech Support <br>" & @CRLF & _
"Sent: Thursday, August 03, 2017 9:22 AM<br>" & @CRLF & _
"To: 'nocdata@sample.com'<br>" & @CRLF & _
"Cc: Example Tech Support<br>" & @CRLF & _
"Subject: 81434 | WIN - Reparian Riverfront - EoC 10MB - Partial Impact<br>" & @CRLF & _
"<br>" & @CRLF & _
"Hello,<br>" & @CRLF & _
"<br>" & @CRLF & _
"Update regarding results of ILEC dispatch to prem this date. ILEC technician repaired the loop that was down (loop 3), but another loop (loop 4) developed a problem while he was there and is now bouncing. Loop 4 has been removed from the efm-group to prevent it from affecting the circuit and a ticket opened with the ILEC for its repair (commit 08/14).<br>" & @CRLF & _
"<br>" & @CRLF & _
"At this time, the 10Mb circuit is up at 9.8Mbps on 3 loops.<br>" & @CRLF & _
"<br>" & @CRLF & _
"<br>" & @CRLF & _
"If you have any further questions, comments or concerns regarding this message, please contact Example NOC support as documented below.<br>" & @CRLF & _
"<br>" & @CRLF & _
"Thank you,<br>" & @CRLF & _
"<br>" & @CRLF & _
"-------------------------------------<br>" & @CRLF & _
"Judy Garland<br>" & @CRLF & _
"NOC Technician<br>" & @CRLF & _
"<br>" & @CRLF & _
"transbeam.com<br>" & @CRLF & _
"<br>" & @CRLF & _
"=======================================================================<br>" & @CRLF & _
"Support Escalations<br>" & @CRLF & _
"Level I: NOC Technician - support@example.com | O: 989.571.1000<br>" & @CRLF & _
"Level II: Manager, Network Operations, William Tell - wchen@example.com | O: 212.777.9999 x123 | M: 989.265.9876<br>" & @CRLF & _
"Level III: Vice President, Operations, Blaise Pascal - blaisep@example.com | O: 212.777.9999 x234 | M: 343.301.2822 <br>" & @CRLF & _
"Level IV: Chief Operating Officer: BF Skinner - bskinner@example.com | O: 212.777.9999 x345 | M: 343.337.7775<br>" & @CRLF & _
"<br>" & @CRLF & _
"" & @CRLF & _
" </td>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")