re = /241(?!50)(?!9)\d{9}L\d{3}/m
str = '241200241511L002
241500241511L002
241900241511L002'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end