using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\\)(?:\w*[rR]ef\*?))(\{.*?\})";
string input = @"\ref{label}
ref{}
\ref
\Ref{}
text \ref{text} text
\ref{text} text }
\ref*{}
\ref{{{{{{}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}