re = /((\\)(?:\w*[rR]ef\*?))(\{.*?\})/
str = '\\ref{label}
ref{}
\\ref
\\Ref{}
text \\ref{text} text
\\ref{text} text }
\\ref*{}
\\ref{{{{{{}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end