import re
regex = re.compile(r"\b\d+\b", flags=re.MULTILINE)
test_str = ("python3 \n"
"foo 3\n"
"bar4 5 6 8\n"
"This is python3 and learning it takes 100 hours")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)