$re = '/(?(DEFINE)
(?<prefix>)
(?<dummy>x)
)
(?&prefix) unused | (?&prefix) match/x';
$str = 'foo match bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);