const regex = new RegExp('\\d{1,3}(?:[^\\S\\n]?\\d{3})*(?:,\\d+)?(?!\\d)', 'gmu')
const str = `1
100 543,55
100542,55
1,123
123 124,55
1 235,66
67
1234,66
12,4
123456789
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}