$re = '/^(\d+)-(\d+.\d+)@(\d+)([A-Z])$/m';
$str = '6-6.35@4T
12-20.50@12A';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);