package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<[/]?(wd:response)[\s+]?>`)
var str = `<wd:response><wd:response-data></wd:response-data></wd:response >`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}