import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(h[1-6]|p|a|img):\\n[\\w\\-\\.\\d].*(?=\\n{0,}?)";
final String string = "h3:\n"
+ "Lorem, ipsum dolor, sit amet consectetur adipisicing elit. Voluptate, perspiciatis.\n\n"
+ "h4:\n"
+ "Lorem, ipsum dolor, sit amet consectetur adipisicing elit. Voluptate, perspiciatis.\n\n"
+ "p:\n"
+ "Hello this is a paragraph you can add something to our dsle deglet for more and now how to use this for free\n\n"
+ "img:\n"
+ "http://www.icon.in/logoe/gksoedfkle/dfkeadka/img.jpg\n\n"
+ "a:\n"
+ "rahul\n\n"
+ "p:\n"
+ "are you ready for more thing so what do you think\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}