using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\`\`\`\{r \')([A-Za-z0-9-\s]+)";
string substitution = @"**\2**\n\1\2";
string input = @"```{r '2b - Possible causes for discrepancy'}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}