$re = '/\s/m';
$str = 'Почему регулярка не видит пробел? Потому что это был особый пробел.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);