re = /(?:[^;]*;){3}([^;]*);/
str = '00.000000 00.000000; X-XX000-0000-0; France; Paris; Street 12a;'
# Print the match result
str.match(re) do |match|
puts match.to_s
end