# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\+?(-?)0*([[:digit:]]+,[[:digit:]]+?)0*$/\1\2/g;t' <<< "+000099,8420000"