const regex = /^\+?(-?)0*([[:digit:]]+,[[:digit:]]+?)0*$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\+?(-?)0*([[:digit:]]+,[[:digit:]]+?)0*$', 'g')
const str = `+000099,8420000`;
const subst = `\1\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);