import Foundation
let pattern = #"^\+?(-?)0*([[:digit:]]+,[[:digit:]]+?)0*$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"+000099,8420000"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)