#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*((((([0-9A-Fa-f]{1,4})|\*):){7}((([0-9A-Fa-f]{1,4})|\*)|:))|(((([0-9A-Fa-f]{1,4})|\*):){6}(:(([0-9A-Fa-f]{1,4})|\*)|((25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)(\.(25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)){3})|:))|(((([0-9A-Fa-f]{1,4})|\*):){5}(((:(([0-9A-Fa-f]{1,4})|\*)){1,2})|:((25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)(\.(25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)){3})|:))|(((([0-9A-Fa-f]{1,4})|\*):){4}(((:(([0-9A-Fa-f]{1,4})|\*)){1,3})|((:(([0-9A-Fa-f]{1,4})|\*))?:((25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)(\.(25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)){3}))|:))|(((([0-9A-Fa-f]{1,4})|\*):){3}(((:(([0-9A-Fa-f]{1,4})|\*)){1,4})|((:(([0-9A-Fa-f]{1,4})|\*)){0,2}:((25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)(\.(25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)){3}))|:))|(((([0-9A-Fa-f]{1,4})|\*):){2}(((:(([0-9A-Fa-f]{1,4})|\*)){1,5})|((:(([0-9A-Fa-f]{1,4})|\*)){0,3}:((25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)(\.(25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)){3}))|:))|(((([0-9A-Fa-f]{1,4})|\*):){1}(((:(([0-9A-Fa-f]{1,4})|\*)){1,6})|((:(([0-9A-Fa-f]{1,4})|\*)){0,4}:((25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)(\.(25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)){3}))|:))|(:(((:(([0-9A-Fa-f]{1,4})|\*)){1,7})|((:(([0-9A-Fa-f]{1,4})|\*)){0,5}:((25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)(\.(25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)){3}))|:)))\s*$"
Local $sString = "2404:6800:4003:c02::8a" & @CRLF & _
"2404:6800:4003:804::200e" & @CRLF & _
"2001:4998:c:a06::2:4008" & @CRLF & _
"fe80::21d8:f50:c295:c4be" & @CRLF & _
"2001:cdba::e:9652" & @CRLF & _
"2001:cdba:0:0:0:0:3257:9652" & @CRLF & _
"2001:cdba::3257:9652" & @CRLF & _
"2001:cdba::1222" & @CRLF & _
"21DA:D3:0:2F3B:2AA:FF:FE28:9C5A" & @CRLF & _
"2001:cdba::1:2:3:3257:9652" & @CRLF & _
"2404::4003:804::200e" & @CRLF & _
"1234:Fd2:2:1:89::4500" & @CRLF & _
"1234:Fd2:12:1:89::4500" & @CRLF & _
"2001:DB8:0:0:0:0:0:*" & @CRLF & _
"2001:DB8:0:0:0:*:*:*" & @CRLF & _
"2001:DB8::0:*" & @CRLF & _
"2001:DB8:0:0:0:*:0:1" & @CRLF & _
"::" & @CRLF & _
"2001:DB8:0:0:0:*" & @CRLF & _
"2001:*:1" & @CRLF & _
"*" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")