import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*((((([0-9A-Fa-f]{1,4})|\\*):){7}((([0-9A-Fa-f]{1,4})|\\*)|:))|(((([0-9A-Fa-f]{1,4})|\\*):){6}(:(([0-9A-Fa-f]{1,4})|\\*)|((25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]?\\d)(\\.(25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]?\\d)){3})|:))|(((([0-9A-Fa-f]{1,4})|\\*):){5}(((:(([0-9A-Fa-f]{1,4})|\\*)){1,2})|:((25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]?\\d)(\\.(25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]?\\d)){3})|:))|(((([0-9A-Fa-f]{1,4})|\\*):){4}(((:(([0-9A-Fa-f]{1,4})|\\*)){1,3})|((:(([0-9A-Fa-f]{1,4})|\\*))?:((25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]?\\d)(\\.(25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]?\\d)){3}))|:))|(((([0-9A-Fa-f]{1,4})|\\*):){3}(((:(([0-9A-Fa-f]{1,4})|\\*)){1,4})|((:(([0-9A-Fa-f]{1,4})|\\*)){0,2}:((25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]?\\d)(\\.(25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]?\\d)){3}))|:))|(((([0-9A-Fa-f]{1,4})|\\*):){2}(((:(([0-9A-Fa-f]{1,4})|\\*)){1,5})|((:(([0-9A-Fa-f]{1,4})|\\*)){0,3}:((25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]?\\d)(\\.(25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]?\\d)){3}))|:))|(((([0-9A-Fa-f]{1,4})|\\*):){1}(((:(([0-9A-Fa-f]{1,4})|\\*)){1,6})|((:(([0-9A-Fa-f]{1,4})|\\*)){0,4}:((25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]?\\d)(\\.(25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]?\\d)){3}))|:))|(:(((:(([0-9A-Fa-f]{1,4})|\\*)){1,7})|((:(([0-9A-Fa-f]{1,4})|\\*)){0,5}:((25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]?\\d)(\\.(25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]?\\d)){3}))|:)))\\s*$";
final String string = "2404:6800:4003:c02::8a\n"
+ "2404:6800:4003:804::200e\n"
+ "2001:4998:c:a06::2:4008\n"
+ "fe80::21d8:f50:c295:c4be\n"
+ "2001:cdba::e:9652\n"
+ "2001:cdba:0:0:0:0:3257:9652\n"
+ "2001:cdba::3257:9652\n"
+ "2001:cdba::1222\n"
+ "21DA:D3:0:2F3B:2AA:FF:FE28:9C5A\n"
+ "2001:cdba::1:2:3:3257:9652\n"
+ "2404::4003:804::200e\n"
+ "1234:Fd2:2:1:89::4500\n"
+ "1234:Fd2:12:1:89::4500\n"
+ "2001:DB8:0:0:0:0:0:*\n"
+ "2001:DB8:0:0:0:*:*:*\n"
+ "2001:DB8::0:*\n"
+ "2001:DB8:0:0:0:*:0:1\n"
+ "::\n"
+ "2001:DB8:0:0:0:*\n"
+ "2001:*:1\n"
+ "*\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}