$re = '/(?<your_field>\w-\w\w-\w\w\w-\d\d-\w\w\w#\w\w\w\w)/m';
$str = 'fields ............................................. Location=Location#All Locations#Site#City#E-MY-SIT-00-XYZ#TEST, fields..........................';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);