$re = '/\ba\./';
$str = ' a. this is a test string a. test string.some records like a.is';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);