package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^if TYPE_CHECKING:(?:\n\s*from .*)*`)
var str = `if TYPE_CHECKING:
from foo import bar
from x import y
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}