$re = '/^if TYPE_CHECKING:(?:\n\s*from .*)*/m';
$str = 'if TYPE_CHECKING:
from foo import bar
from x import y
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);