package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\b([A-F 0-9]{8})-([A-F 0-9]{4})-([A-F 0-9]{4})-([A-F 0-9]{4})-([A-F 0-9]{12})\b`)
var str = `3a0decee-ca3a-4f39-b3e4-8df6bd25616b`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}