import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "src:\\s*(\\d{1,3}(?:\\.\\d{1,3}){3})\\ndst:\\s*(\\d{1,3}(?:\\.\\d{1,3}){3})(?:\\n(?!severity).+)*?\\nseverity:\\s*(.+)";
final String string = "src: 10.4.180.25\n"
+ "dst: 34.23.21.10\n"
+ "natsrc: 20.160.129.5\n"
+ "natdst: 34.33.21.10\n"
+ "more lines\n"
+ "severity: critical\n"
+ "more lines";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}