const regex = new RegExp('src:\\s*(\\d{1,3}(?:\\.\\d{1,3}){3})\\ndst:\\s*(\\d{1,3}(?:\\.\\d{1,3}){3})(?:\\n(?!severity).+)*?\\nseverity:\\s*(.+)', 'g')
const str = `src: 10.4.180.25
dst: 34.23.21.10
natsrc: 20.160.129.5
natdst: 34.33.21.10
more lines
severity: critical
more lines`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}