$re = '/href=(?:"[^"]*"|\'[^\']*\')|([.,])/m';
$str = 'test . <a id="" href=".">test</a> test <a href="test" class=""></a> test with a . dot here
href="text.test" test . test, test href=\'test\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);