using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?!y).+)\s*([+-/])\s*((?!.*x)(?=.*y).+)\s*=.+";
string input = @"x^2 + y^2=1
69/7+ x^2+y^2=1
x^2-y^2/2=1
sinx^2-cosy^2=1
(x^2-1/2(3*5))-cosy^2=1
sinx^2-cosy^2+58=1
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}