import Foundation
let pattern = #"((?!y).+)\s*([+-/])\s*((?!.*x)(?=.*y).+)\s*=.+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
x^2 + y^2=1
69/7+ x^2+y^2=1
x^2-y^2/2=1
sinx^2-cosy^2=1
(x^2-1/2(3*5))-cosy^2=1
sinx^2-cosy^2+58=1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)