$re = '/h1>(.+?)\s*\((\d*)\)<(?s).+?h2>(.+?)</';
$str = '
<h1>valami szöveg1 (0000)</h1>
<h2>valami szöveg2</h2>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);