# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<fileName>)(.+)?(<\\/fileName>)/\1[!] value does not exist!\3/gm;t' <<< " <file>
<fileType>Mezza</fileType>
<fileName></fileName>
<segments>0000</segments>
</file>"