#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(<fileName>)(.+)?(<\/fileName>)"
Local $sString = " <file> " & @CRLF & _
" <fileType>Mezza</fileType>" & @CRLF & _
" <fileName></fileName>" & @CRLF & _
" <segments>0000</segments>" & @CRLF & _
" </file>"
Local $sSubst = "\1[!] value does not exist!\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)