using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<fileName>)(.+)?(<\/fileName>)";
string substitution = @"\1[!] value does not exist!\3";
string input = @" <file>
<fileType>Mezza</fileType>
<fileName></fileName>
<segments>0000</segments>
</file>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}