const regex = new RegExp('(<fileName>)(.+)?(<\\/fileName>)', 'gm')
const str = ` <file>
<fileType>Mezza</fileType>
<fileName></fileName>
<segments>0000</segments>
</file>`;
const subst = `\1[!] value does not exist!\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);