import Foundation
let pattern = #"(<fileName>)(.+)?(<\/fileName>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<file>
<fileType>Mezza</fileType>
<fileName></fileName>
<segments>0000</segments>
</file>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1[!] value does not exist!\3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)