#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(https?://.*?)(/courses/(?:\d+)/quizzes/(?:\d+))/?(?:take)?"
Local $sString = "https://k12.instructure.com/courses/651977/quizzes/1116753/take"
Local $sSubst = "\1/api/v1\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)