import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?://.*?)(/courses/(?:\\d+)/quizzes/(?:\\d+))/?(?:take)?";
final String string = "https://k12.instructure.com/courses/651977/quizzes/1116753/take";
final String subst = "\\1/api/v1\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}