re = /(https?:\/\/.*?)(\/courses\/(?:\d+)\/quizzes\/(?:\d+))\/?(?:take)?/m
str = 'https://k12.instructure.com/courses/651977/quizzes/1116753/take'
subst = '\\1/api/v1\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result