using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"name=""(.*?)"" value=""(.*?)""";
string input = @"<input type=""hidden"" name=""semvalue"">
<input type=""hidden"" value=""abc"">";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}