package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)name="(.*?)" value="(.*?)"`)
var str = `<input type="hidden" name="semvalue">
<input type="hidden" value="abc">`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}