#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(<img )(src="[^"]*\/)(.+?)(\..+?\>)"
Local $sString = "<img src="../arbitrary/file/path/file-name.jpg" alt="arbitrary alt tag"></img>" & @CRLF & _
"" & @CRLF & _
"<img src="../arbitrary/file/path/file-name.jpg" alt="arbitrary alt tag" /><img></img>" & @CRLF & _
"" & @CRLF & _
"<img src="../arbitrary/file/path/file-name.jpg" alt="arbitrary alt tag f/1.6" />"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")