// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(<img )(src="[^"]*\/)(.+?)(\..+?\>)"#).unwrap();
let string = "<img src=\"../arbitrary/file/path/file-name.jpg\" alt=\"arbitrary alt tag\"></img>
<img src=\"../arbitrary/file/path/file-name.jpg\" alt=\"arbitrary alt tag\" /><img></img>
<img src=\"../arbitrary/file/path/file-name.jpg\" alt=\"arbitrary alt tag f/1.6\" />";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}