# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<a[^>]*>(*SKIP)(*FAIL)|"/"/gm;t' <<< "Lorem ipsum dolor sit amet, \"consetetur\" sadipscing elitr.
<ul>
<li>At vero eos et accusam et justo</li
<li>Stet clita \"kasd\" gubergren</li>
</ul>
<a href=\"https://www.google.com/\" target=\"_blank\">https://www.google.com/</a>
\"At vero eos et accusam et justo duo dolores et ea rebum. , no sea takimata sanctus est Lorem ipsum dolor sit amet.\""