#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<a[^>]*>(*SKIP)(*FAIL)|""
Local $sString = "Lorem ipsum dolor sit amet, "consetetur" sadipscing elitr." & @CRLF & _
"" & @CRLF & _
"<ul>" & @CRLF & _
"<li>At vero eos et accusam et justo</li" & @CRLF & _
"<li>Stet clita "kasd" gubergren</li>" & @CRLF & _
"</ul>" & @CRLF & _
"" & @CRLF & _
"<a href="https://www.google.com/" target="_blank">https://www.google.com/</a>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""At vero eos et accusam et justo duo dolores et ea rebum. , no sea takimata sanctus est Lorem ipsum dolor sit amet.""
Local $sSubst = """
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)