const regex = /<a[^>]*>(*SKIP)(*FAIL)|"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a[^>]*>(*SKIP)(*FAIL)|"', 'gm')
const str = `Lorem ipsum dolor sit amet, "consetetur" sadipscing elitr.
<ul>
<li>At vero eos et accusam et justo</li
<li>Stet clita "kasd" gubergren</li>
</ul>
<a href="https://www.google.com/" target="_blank">https://www.google.com/</a>
"At vero eos et accusam et justo duo dolores et ea rebum. , no sea takimata sanctus est Lorem ipsum dolor sit amet."`;
const subst = `"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);