// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<a[^>]*>(*SKIP)(*FAIL)|""#).unwrap();
let string = "Lorem ipsum dolor sit amet, \"consetetur\" sadipscing elitr.
<ul>
<li>At vero eos et accusam et justo</li
<li>Stet clita \"kasd\" gubergren</li>
</ul>
<a href=\"https://www.google.com/\" target=\"_blank\">https://www.google.com/</a>
\"At vero eos et accusam et justo duo dolores et ea rebum. , no sea takimata sanctus est Lorem ipsum dolor sit amet.\"";
let substitution = """;
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}