using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?sx)User:\h([^\n]+)\n
Login\-name:\h([^\n]+)\n
(?:CaseSensitive:\h([^\n]+)\n)?
NTSecurity:\h([^\n]+)\n
(?:NO\n)?
(?:Domain:\h([^\n]+)\n)?
Timeout:\h([^\n]+)\n
.*?
Member:\h([^\n]+)\n";
string input = @"User: AMMINISTRATORE
Login-name: ADM
CaseSensitive: YES
NTSecurity: NO
NO
Timeout: 00:05:00
Member: AMMINISTRATORI
User: Test_User
Login-name: Test_User
NTSecurity: YES
Domain: DNEU
Timeout: 00:00:00
Member: OPERATORS
Member: OPERATORS";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}