const regex = /(?sx)User:\h([^\n]+)\n
Login\-name:\h([^\n]+)\n
(?:CaseSensitive:\h([^\n]+)\n)?
NTSecurity:\h([^\n]+)\n
(?:NO\n)?
(?:Domain:\h([^\n]+)\n)?
Timeout:\h([^\n]+)\n
.*?
Member:\h([^\n]+)\n/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?sx)User:\\h([^\\n]+)\\n
Login\\-name:\\h([^\\n]+)\\n
(?:CaseSensitive:\\h([^\\n]+)\\n)?
NTSecurity:\\h([^\\n]+)\\n
(?:NO\\n)?
(?:Domain:\\h([^\\n]+)\\n)?
Timeout:\\h([^\\n]+)\\n
.*?
Member:\\h([^\\n]+)\\n', 'g')
const str = `User: AMMINISTRATORE
Login-name: ADM
CaseSensitive: YES
NTSecurity: NO
NO
Timeout: 00:05:00
Member: AMMINISTRATORI
User: Test_User
Login-name: Test_User
NTSecurity: YES
Domain: DNEU
Timeout: 00:00:00
Member: OPERATORS
Member: OPERATORS`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}