use strict;
my $str = 'User: AMMINISTRATORE
Login-name: ADM
CaseSensitive: YES
NTSecurity: NO
NO
Timeout: 00:05:00
Member: AMMINISTRATORI
User: Test_User
Login-name: Test_User
NTSecurity: YES
Domain: DNEU
Timeout: 00:00:00
Member: OPERATORS
Member: OPERATORS';
my $regex = qr/(?sx)User:\h([^\n]+)\n
Login\-name:\h([^\n]+)\n
(?:CaseSensitive:\h([^\n]+)\n)?
NTSecurity:\h([^\n]+)\n
(?:NO\n)?
(?:Domain:\h([^\n]+)\n)?
Timeout:\h([^\n]+)\n
.*?
Member:\h([^\n]+)\n/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}