# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^h[1,3,5]\-ars0(?:[1-5]\-v|[6,7])\.eset\.com$"
test_str = ("h1-ars01-v.eset.com\n"
"h1-ars02-v.eset.com\n"
"h1-ars03-v.eset.com\n"
"h1-ars04-v.eset.com\n"
"h1-ars05-v.eset.com\n\n"
"h1-ars06.eset.com\n"
"h1-ars07.eset.com\n\n"
"h3-ars01-v.eset.com\n"
"h3-ars02-v.eset.com\n"
"h3-ars03-v.eset.com\n"
"h3-ars04-v.eset.com\n"
"h3-ars05-v.eset.com\n\n"
"h3-ars06.eset.com\n"
"h3-ars07.eset.com\n\n"
"h5-ars01-v.eset.com\n"
"h5-ars02-v.eset.com\n"
"h5-ars03-v.eset.com\n"
"h5-ars04-v.eset.com\n"
"h5-ars05-v.eset.com\n\n"
"h5-ars06.eset.com\n"
"h5-ars07.eset.com\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.