import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\#[\\da-f]{3}|\\#[\\da-f]{6}|rgba\\(((\\d{1,2}|1\\d\\d|2([0-4]\\d|5[0-5]))\\s*,\\s*){2}((\\d{1,2}|1\\d\\d|2([0-4]\\d|5[0-5]))\\s*)(,\\s*(0\\.\\d+|1))\\)|hsla\\(\\s*((\\d{1,2}|[1-2]\\d{2}|3([0-5]\\d|60)))\\s*,\\s*((\\d{1,2}|100)\\s*%)\\s*,\\s*((\\d{1,2}|100)\\s*%)(,\\s*(0\\.\\d+|1))\\)|rgb\\(((\\d{1,2}|1\\d\\d|2([0-4]\\d|5[0-5]))\\s*,\\s*){2}((\\d{1,2}|1\\d\\d|2([0-4]\\d|5[0-5]))\\s*)\\)|hsl\\(\\s*((\\d{1,2}|[1-2]\\d{2}|3([0-5]\\d|60)))\\s*,\\s*((\\d{1,2}|100)\\s*%)\\s*,\\s*((\\d{1,2}|100)\\s*%)\\))$";
final String string = "rgb(234, 160, 160)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}